What’s Vulnerable › Vulnerabilities
CVE-2023-2122: Image Optimizer by 10web < 1.0.27 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-16 · updated 2026-06-17
Description
The Image Optimizer by 10web WordPress plugin before 1.0.27 does not sanitise and escape the iowd_tabs_active parameter before rendering it in the plugin admin panel, leading to a reflected Cross-Site Scripting vulnerability, allowing an attacker to trick a logged in admin to execute arbitrary javascript by clicking a link.
Affected products
- Image Optimizer by 10web: before 1.0.27 — fixed in 1.0.27
How to fix
Upgrade to a fixed version: Image Optimizer by 10web 1.0.27. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/936fd93a-428d-4744-a4fc-c8da78dcbe78
- https://wpscan.com/vulnerability/936fd93a-428d-4744-a4fc-c8da78dcbe78
Get alerted when CVE-2023-2122 or the next vulnerability affects your stack