What’s Vulnerable › Vulnerabilities

CVE-2023-2132

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A DollarMathPostFilter Regular Expression Denial of Service in was possible by sending crafted payloads to the preview_markdown endpoint.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.10.8, 15.11.7, 16.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2132 or the next vulnerability affects your stack