What’s Vulnerable › Vulnerabilities
CVE-2023-21391
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-30 · updated 2026-06-17
- Weakness: CWE-20
Description
In Messaging, there is a possible way to disable the messaging application due to improper input validation. This could lead to remote denial of service with no additional execution privileges needed. User interaction is not needed for exploitation.
Affected products
- Android: before 14.0 — fixed in 14.0
How to fix
Upgrade to a fixed version: Android 14.0. Check the vendor advisory for mitigations.
References
- https://source.android.com/docs/security/bulletin/android-14
- https://source.android.com/docs/security/bulletin/android-14
Get alerted when CVE-2023-21391 or the next vulnerability affects your stack