What’s Vulnerable › Vulnerabilities
CVE-2023-21415
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-35
Description
Sandro Poppi, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API overlay_del.cgi is vulnerable to path traversal attacks that allows for file deletion. This flaw can only be exploited after authenticating with an operator- or administrator-privileged service account. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: from 6.50.5.3 before 6.50.5.14; from 11.0.81 before 11.6.94 — fixed in 11.6.94, 6.50.5.14
- Axis Os 2016: from 6.50.2 before 6.50.5.2 — fixed in 6.50.5.2
- Axis Os 2018: before 8.40.35 — fixed in 8.40.35
- Axis Os 2020: before 9.80.47 — fixed in 9.80.47
- Axis Os 2022: before 10.12.206 — fixed in 10.12.206
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 11.6.94, 6.50.5.14; Axis Os 2016 6.50.5.2; Axis Os 2018 8.40.35; Axis Os 2020 9.80.47; Axis Os 2022 10.12.206. Check the vendor advisory for mitigations.
References
- https://www.axis.com/dam/public/b6/55/e2/cve-2023-21415pdf-en-US-416245.pdf
- https://www.axis.com/dam/public/b6/55/e2/cve-2023-21415pdf-en-US-416245.pdf
Get alerted when CVE-2023-21415 or the next vulnerability affects your stack