What’s Vulnerable › Vulnerabilities
CVE-2023-21416
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-21 · updated 2026-06-17
- Weakness: CWE-35
Description
Sandro Poppi, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API dynamicoverlay.cgi was vulnerable to a Denial-of-Service attack allowing for an attacker to block access to the overlay configuration page in the web interface of the Axis device. This flaw can only be exploited after authenticating with an operator- or administrator-privileged service account however the impact is equal. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: before 11.7.57 — fixed in 11.7.57
- Axis Os 2022: before 10.12.213 — fixed in 10.12.213
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 11.7.57; Axis Os 2022 10.12.213. Check the vendor advisory for mitigations.
References
- https://www.axis.com/dam/public/35/2a/a6/cve-2023-21416-en-US-417790.pdf
- https://www.axis.com/dam/public/35/2a/a6/cve-2023-21416-en-US-417790.pdf
Get alerted when CVE-2023-21416 or the next vulnerability affects your stack