What’s Vulnerable › Vulnerabilities
CVE-2023-21417
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-21 · updated 2026-06-17
- Weakness: CWE-35
Description
Sandro Poppi, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API manageoverlayimage.cgi was vulnerable to path traversal attacks that allows for file/folder deletion. This flaw can only be exploited after authenticating with an operator- or administrator- privileged service account. The impact of exploiting this vulnerability is lower with operator service accounts and limited to non-system files compared to administrator-privileges. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: before 11.7.57 — fixed in 11.7.57
- Axis Os 2020: before 9.80.49 — fixed in 9.80.49
- Axis Os 2022: before 10.12.208 — fixed in 10.12.208
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 11.7.57; Axis Os 2020 9.80.49; Axis Os 2022 10.12.208. Check the vendor advisory for mitigations.
References
- https://www.axis.com/dam/public/2a/82/12/cve-2023-21417-en-US-417791.pdf
- https://www.axis.com/dam/public/2a/82/12/cve-2023-21417-en-US-417791.pdf
Get alerted when CVE-2023-21417 or the next vulnerability affects your stack