What’s Vulnerable › Vulnerabilities
CVE-2023-21418
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-21 · updated 2026-06-17
- Weakness: CWE-35
Description
Sandro Poppi, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API irissetup.cgi was vulnerable to path traversal attacks that allows for file deletion. This flaw can only be exploited after authenticating with an operator- or administrator-privileged service account. The impact of exploiting this vulnerability is lower with operator service accounts and limited to non-system files compared to administrator-privileges. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: before 6.50.5.15; before 11.7.57 — fixed in 11.7.57, 6.50.5.15
- Axis Os 2018: before 8.40.35 — fixed in 8.40.35
- Axis Os 2020: before 9.80.49 — fixed in 9.80.49
- Axis Os 2022: before 10.12.213 — fixed in 10.12.213
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 11.7.57, 6.50.5.15; Axis Os 2018 8.40.35; Axis Os 2020 9.80.49; Axis Os 2022 10.12.213. Check the vendor advisory for mitigations.
References
- https://www.axis.com/dam/public/49/93/55/cve-2023-21418-en-US-417792.pdf
- https://www.axis.com/dam/public/49/93/55/cve-2023-21418-en-US-417792.pdf
Get alerted when CVE-2023-21418 or the next vulnerability affects your stack