What’s Vulnerable › Vulnerabilities
CVE-2023-21531: Azure Service Fabric Container Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-284
Description
Azure Service Fabric Container Elevation of Privilege Vulnerability
Affected products
- Microsoft Azure Service Fabric for Linux: 8.2, 9.0, 9.1
- Microsoft Azure Service Fabric 8.2: from 8.2 before 8.2 CU8 — fixed in 8.2 CU8
- Microsoft Azure Service Fabric 9.0 for Linux: from 9.0 before 9.0 CU5 — fixed in 9.0 CU5
- Microsoft Azure Service Fabric 9.1: from 9.1 before 9.1 CU1 — fixed in 9.1 CU1
How to fix
Upgrade to a fixed version: Microsoft Azure Service Fabric 8.2 8.2 CU8; Microsoft Azure Service Fabric 9.0 for Linux 9.0 CU5; Microsoft Azure Service Fabric 9.1 9.1 CU1. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21531
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21531
Get alerted when CVE-2023-21531 or the next vulnerability affects your stack