What’s Vulnerable › Vulnerabilities
CVE-2023-21538: .NET Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-502
Description
.NET Denial of Service Vulnerability
Affected products
- Fedoraproject Fedora: 36, 37
- Microsoft .NET: 6.0.0
- Microsoft Powershell: 7.2
- Microsoft .NET 6.0: from 6.0.0 before 6.0.13 — fixed in 6.0.13
- Microsoft PowerShell 7.2: from 7.2.0 before 7.2.9 — fixed in 7.2.9
How to fix
Upgrade to a fixed version: Microsoft .NET 6.0 6.0.13; Microsoft PowerShell 7.2 7.2.9. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21538
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21538
Get alerted when CVE-2023-21538 or the next vulnerability affects your stack