What’s Vulnerable › Vulnerabilities
CVE-2023-21566: Visual Studio Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-08-19
- Weakness: CWE-73
Description
Visual Studio Elevation of Privilege Vulnerability
Affected products
- Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8): from 15.0 before 15.9.52 — fixed in 15.9.52
- Microsoft Visual Studio 2019: from 16.0 before 16.11.24 — fixed in 16.11.24
- Microsoft Visual Studio 2022 version 17.14: from 17.0 before 17.0.19; from 17.2 before 17.2.13; from 17.4 before 17.4.5 — fixed in 17.0.19, 17.2.13, 17.4.5
- Microsoft Visual Studio 2019 version 16.11 (includes 16.0 - 16.10): from 16.11.0 before 16.11.24 — fixed in 16.11.24
- Microsoft Visual Studio 2022 version 17.0: from 17.0.0 before 17.0.19 — fixed in 17.0.19
- Microsoft Visual Studio 2022 version 17.2: from 17.2.0 before 17.2.13 — fixed in 17.2.13
- Microsoft Visual Studio 2022 version 17.4: from 17.4.0 before 17.4.5 — fixed in 17.4.5
- Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8): from 15.9.0 before 15.9.52 — fixed in 15.9.52
How to fix
Upgrade to a fixed version: Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8) 15.9.52; Microsoft Visual Studio 2019 16.11.24; Microsoft Visual Studio 2022 version 17.14 17.0.19, 17.2.13, 17.4.5; Microsoft Visual Studio 2019 version 16.11 (includes 16.0 - 16.10) 16.11.24; Microsoft Visual Studio 2022 version 17.0 17.0.19; Microsoft Visual Studio 2022 version 17.2 17.2.13; Microsoft Visual Studio 2022 version 17.4 17.4.5; Microsoft Visual Studio 2017 version 15.9 (includes 15.0 - 15.8) 15.9.52. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21566
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21566
Get alerted when CVE-2023-21566 or the next vulnerability affects your stack