What’s Vulnerable › Vulnerabilities
CVE-2023-2157
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-06 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap-based buffer overflow vulnerability was found in the ImageMagick package that can lead to the application crashing.
Affected products
- ImageMagick: before 7.1.1-9 — fixed in 7.1.1-9
How to fix
Upgrade to a fixed version: ImageMagick 7.1.1-9. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2208537
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/45DUUXYMAEEAW55GSLAXN25VPKCRAIDA/
- https://bugzilla.redhat.com/show_bug.cgi?id=2208537
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/45DUUXYMAEEAW55GSLAXN25VPKCRAIDA/
Get alerted when CVE-2023-2157 or the next vulnerability affects your stack