What’s Vulnerable › Vulnerabilities

CVE-2023-21578: Adobe Photoshop Font Parsing Out-Of-Bounds Read Information Disclosure Vulnerability

Description

Photoshop version 23.5.3 (and earlier), 24.1 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Photoshop 23.5.4, 24.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-21578 or the next vulnerability affects your stack