What’s Vulnerable › Vulnerabilities
CVE-2023-2162
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-19 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free vulnerability was found in iscsi_sw_tcp_session_create in drivers/scsi/iscsi_tcp.c in SCSI sub-component in the Linux Kernel. In this flaw an attacker could leak kernel internal information.
Affected products
- Linux kernel: before 6.2; 6.2, 6.2-rc1, 6.2-rc2, 6.2-rc3, 6.2-rc4, 6.2-rc5 — fixed in 6.2
How to fix
Upgrade to a fixed version: Linux kernel 6.2. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://www.spinics.net/lists/linux-scsi/msg181542.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://www.spinics.net/lists/linux-scsi/msg181542.html
Get alerted when CVE-2023-2162 or the next vulnerability affects your stack