What’s Vulnerable › Vulnerabilities

CVE-2023-2164: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab affecting all versions starting from 15.9 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. It was possible for an attacker to trigger a stored XSS vulnerability via user interaction with a crafted URL in the WebIDE beta.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.0.8, 16.1.3, 16.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2164 or the next vulnerability affects your stack