What’s Vulnerable › Vulnerabilities
CVE-2023-21717: Microsoft SharePoint Server Elevation of Privilege Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-14 · updated 2026-08-19
- Weakness: CWE-284
Description
Microsoft SharePoint Server Elevation of Privilege Vulnerability
Affected products
- Microsoft SharePoint Server: 2013-sp1, 2016
- Microsoft SharePoint Foundation 2013 Service Pack 1: 2013-sp1
- Microsoft SharePoint Server: 2019
- Microsoft SharePoint Enterprise Server 2013 Service Pack 1: from 15.0.0 before 15.0.5529.1000 — fixed in 15.0.5529.1000
- Microsoft SharePoint Server Subscription Edition: from 16.0.0 before 16.0.15601.20478 — fixed in 16.0.15601.20478
- Microsoft Sharepoint Enterprise Server 2016: from 16.0.0 before 16.0.5383.1000 — fixed in 16.0.5383.1000
- Microsoft SharePoint Foundation 2013 Service Pack 1: from 15.0.0 before 15.0.5529.1000 — fixed in 15.0.5529.1000
- Microsoft SharePoint Server: from 16.0.0 before 16.0.10395.20001 — fixed in 16.0.10395.20001
How to fix
Upgrade to a fixed version: Microsoft SharePoint Enterprise Server 2013 Service Pack 1 15.0.5529.1000; Microsoft SharePoint Server Subscription Edition 16.0.15601.20478; Microsoft Sharepoint Enterprise Server 2016 16.0.5383.1000; Microsoft SharePoint Foundation 2013 Service Pack 1 15.0.5529.1000; Microsoft SharePoint Server 16.0.10395.20001. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21717
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21717
Get alerted when CVE-2023-21717 or the next vulnerability affects your stack