What’s Vulnerable › Vulnerabilities
CVE-2023-21755: Windows Kernel Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-416
Description
Windows Kernel Elevation of Privilege Vulnerability
Affected products
- Microsoft Windows 10 1607: all versions
- Microsoft Windows 10: all versions
- Microsoft Windows 10 20H2: all versions
- Microsoft Windows 10: all versions
- Microsoft Windows 10: all versions
- Microsoft Windows 11 21H2: all versions
- Microsoft Windows 11: all versions
- Microsoft Windows 7: all versions
- Microsoft Windows 8.1: all versions
- Microsoft Windows RT 8.1: all versions
- Microsoft Windows Server 2008: r2-sp1
- Microsoft Windows Server 2012: r2
- Microsoft Windows Server 2016: all versions
- Microsoft Windows Server 2019: all versions
- Microsoft Windows Server 2022: all versions
- Microsoft Windows 10: from 10.0.17763.0 before 10.0.17763.3887 — fixed in 10.0.17763.3887
- Microsoft Windows 10 20H2: from 10.0.0 before 10.0.19042.2486 — fixed in 10.0.19042.2486
- Microsoft Windows 10: from 10.0.19043.0 before 10.0.19044.2486 — fixed in 10.0.19044.2486
- Microsoft Windows 10: from 10.0.19045.0 before 10.0.19045.2486 — fixed in 10.0.19045.2486
- Microsoft Windows 11 21H2: from 10.0.0 before 10.0.22000.1455 — fixed in 10.0.22000.1455
- Microsoft Windows 11: from 10.0.22621.0 before 10.0.22621.1105 — fixed in 10.0.22621.1105
How to fix
Upgrade to a fixed version: Microsoft Windows 10 10.0.17763.3887; Microsoft Windows 10 20H2 10.0.19042.2486; Microsoft Windows 10 10.0.19044.2486; Microsoft Windows 10 10.0.19045.2486; Microsoft Windows 11 21H2 10.0.22000.1455; Microsoft Windows 11 10.0.22621.1105. Check the vendor advisory for mitigations.
References
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21755
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2023-21755
Get alerted when CVE-2023-21755 or the next vulnerability affects your stack