What’s Vulnerable › Vulnerabilities

CVE-2023-2181

Description

An issue has been discovered in GitLab affecting all versions before 15.9.8, 15.10.0 before 15.10.7, and 15.11.0 before 15.11.3. A malicious developer could use a git feature called refs/replace to smuggle content into a merge request which would not be visible during review in the UI.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.10.7, 15.11.3, 15.9.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2181 or the next vulnerability affects your stack