What’s Vulnerable › Vulnerabilities

CVE-2023-2182

Description

An issue has been discovered in GitLab EE affecting all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. Under certain conditions when OpenID Connect is enabled on an instance, it may allow users who are marked as 'external' to become 'regular' users thus leading to privilege escalation for those users.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.10.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-2182 or the next vulnerability affects your stack