What’s Vulnerable › Vulnerabilities
CVE-2023-2188: Colibri Page Builder <= 1.0.227 - Authenticated (Administrator+) SQL Injection via post_id
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-31 · updated 2026-06-17
- Weakness: CWE-89
Description
The Colibri Page Builder for WordPress is vulnerable to SQL Injection via the ‘post_id’ parameter in versions up to, and including, 1.0.227 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with administrator-level privileges to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- extendthemes Colibri Page Builder: before 1.0.229 — fixed in 1.0.229
How to fix
Upgrade to a fixed version: extendthemes Colibri Page Builder 1.0.229. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/utils.php#L556
- https://plugins.trac.wordpress.org/changeset/2922722/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c73d4b78-72aa-409a-a787-898179773b82?source=cve
- https://plugins.trac.wordpress.org/browser/colibri-page-builder/trunk/extend-builder/utils.php#L556
- https://plugins.trac.wordpress.org/changeset/2922722/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c73d4b78-72aa-409a-a787-898179773b82?source=cve
Get alerted when CVE-2023-2188 or the next vulnerability affects your stack