What’s Vulnerable › Vulnerabilities
CVE-2023-22094
- Severity: high (CVSS 7.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-17 · updated 2026-06-17
Description
Vulnerability in the MySQL Installer product of Oracle MySQL (component: Installer: General). Supported versions that are affected are Prior to 1.6.8. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where MySQL Installer executes to compromise MySQL Installer. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in MySQL Installer, attacks may significantly impact additional products (scope change). Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all MySQL Installer accessible data and unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Installer. Note: This patch is used in MySQL Server bundled version 8.0.35 and 5.7.44. CVSS 3.1 Base Score 7.9 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:H).
Affected products
- Oracle Corporation MySQL Installer: before 1.6.8 — fixed in 1.6.8
How to fix
Upgrade to a fixed version: Oracle Corporation MySQL Installer 1.6.8. Check the vendor advisory for mitigations.
References
- https://www.oracle.com/security-alerts/cpuoct2023.html
- https://www.oracle.com/security-alerts/cpuoct2023.html
Get alerted when CVE-2023-22094 or the next vulnerability affects your stack