What’s Vulnerable › Vulnerabilities
CVE-2023-2221: WP Custom Cursors < 3.2 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-19 · updated 2026-06-17
Description
The WP Custom Cursors WordPress plugin before 3.2 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by users with a role as low as Admin.
Affected products
- WP Custom Cursors | WordPress Cursor Plugin: before 3.2 — fixed in 3.2
How to fix
Upgrade to a fixed version: WP Custom Cursors | WordPress Cursor Plugin 3.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6666688e-7239-4d40-a348-307cf8f3b657
- https://wpscan.com/vulnerability/6666688e-7239-4d40-a348-307cf8f3b657
- https://wpscan.com/vulnerability/6666688e-7239-4d40-a348-307cf8f3b657/
Get alerted when CVE-2023-2221 or the next vulnerability affects your stack