What’s Vulnerable › Vulnerabilities
CVE-2023-2223: Login Rebuilder < 2.8.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The Login rebuilder WordPress plugin before 2.8.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Login rebuilder: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: Login rebuilder 2.8.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/173726/WordPress-Login-Rebuilder-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/7b356b82-5d03-4f70-b4ce-f1405304bb52
- http://packetstormsecurity.com/files/173726/WordPress-Login-Rebuilder-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/7b356b82-5d03-4f70-b4ce-f1405304bb52
Get alerted when CVE-2023-2223 or the next vulnerability affects your stack