What’s Vulnerable › Vulnerabilities
CVE-2023-22233: Adobe After Effects Font Parsing Out-Of-Bounds Read Information Disclosure Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-17 · updated 2026-06-17
- Weakness: CWE-125
Description
After Affects versions 23.1 (and earlier), 22.6.3 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: from 22.0.0 before 22.6.4; from 23.0.0 before 23.2.0 — fixed in 22.6.4, 23.2.0
How to fix
Upgrade to a fixed version: Adobe After Effects 22.6.4, 23.2.0. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/after_effects/apsb23-02.html
- https://helpx.adobe.com/security/products/after_effects/apsb23-02.html
Get alerted when CVE-2023-22233 or the next vulnerability affects your stack