What’s Vulnerable › Vulnerabilities
CVE-2023-22239: Adobe After Effects Improper Input Validation Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-17 · updated 2026-06-17
- Weakness: CWE-20
Description
After Affects versions 23.1 (and earlier), 22.6.3 (and earlier) are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe After Effects: from 22.0.0 before 22.6.4; from 23.0.0 before 23.2.0 — fixed in 22.6.4, 23.2.0
How to fix
Upgrade to a fixed version: Adobe After Effects 22.6.4, 23.2.0. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/after_effects/apsb23-02.html
- https://helpx.adobe.com/security/products/after_effects/apsb23-02.html
Get alerted when CVE-2023-22239 or the next vulnerability affects your stack