What’s Vulnerable › Vulnerabilities
CVE-2023-2224: Seo By 10Web < 1.2.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The SEO by 10Web WordPress plugin before 1.2.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- SEO by 10Web: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: SEO by 10Web 1.2.7. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/173725/WordPress-Seo-By-10Web-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/a76b6d22-1e00-428a-8a04-12162bd0d992
- http://packetstormsecurity.com/files/173725/WordPress-Seo-By-10Web-Cross-Site-Scripting.html
- https://wpscan.com/vulnerability/a76b6d22-1e00-428a-8a04-12162bd0d992
Get alerted when CVE-2023-2224 or the next vulnerability affects your stack