What’s Vulnerable › Vulnerabilities
CVE-2023-22241: ZDI-CAN-19516: Adobe Acrobat Reader DC AcroForm Annotation Out-Of-Bounds Write Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Acrobat Reader versions 22.003.20282 (and earlier), 22.003.20281 (and earlier) and 20.005.30418 (and earlier) are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 20.001.30005 before 20.005.30436 — fixed in 20.005.30436
- Adobe Acrobat DC: before 22.003.20310 — fixed in 22.003.20310
- Adobe Acrobat Reader: from 20.001.30005 before 20.005.30436 — fixed in 20.005.30436
- Adobe Acrobat Reader: before 22.003.20310 — fixed in 22.003.20310
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.005.30436; Adobe Acrobat DC 22.003.20310; Adobe Acrobat Reader 20.005.30436; Adobe Acrobat Reader 22.003.20310. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb23-01.html
- https://helpx.adobe.com/security/products/acrobat/apsb23-01.html
Get alerted when CVE-2023-22241 or the next vulnerability affects your stack