What’s Vulnerable › Vulnerabilities
CVE-2023-22247: Adobe Commerce XML Injection Arbitrary file system read
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-91
Description
Adobe Commerce versions 2.4.4-p2 (and earlier) and 2.4.5-p1 (and earlier) are affected by an XML Injection vulnerability that could lead to arbitrary file system read. An unauthenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction.
Affected products
- Adobe Commerce: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.5, 2.4.5-p1 — fixed in 2.4.4
- Adobe Magento Open Source: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.5, 2.4.5-p1 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4; Adobe Magento Open Source 2.4.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb23-17.html
- https://helpx.adobe.com/security/products/magento/apsb23-17.html
Get alerted when CVE-2023-22247 or the next vulnerability affects your stack