What’s Vulnerable › Vulnerabilities
CVE-2023-22249: Adobe Commerce Stored XSS Arbitrary code execution
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 58.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Adobe Commerce versions 2.4.4-p2 (and earlier) and 2.4.5-p1 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Affected products
- Adobe Commerce: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.5, 2.4.5-p1 — fixed in 2.4.4
- Adobe Magento Open Source: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p2, 2.4.5, 2.4.5-p1 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4; Adobe Magento Open Source 2.4.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb23-17.html
- https://helpx.adobe.com/security/products/magento/apsb23-17.html
Get alerted when CVE-2023-22249 or the next vulnerability affects your stack