What’s Vulnerable › Vulnerabilities
CVE-2023-2227: Improper Authorization in modoboa/modoboa
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 44.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-21 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper Authorization in GitHub repository modoboa/modoboa prior to 2.1.0.
Affected products
- modoboa/modoboa: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: modoboa/modoboa 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/modoboa/modoboa/commit/7bcd3f6eb264d4e3e01071c97c2bac51cdd6fe97
- https://huntr.dev/bounties/351f9055-2008-4af0-b820-01ff66678bf3
- https://github.com/modoboa/modoboa/commit/7bcd3f6eb264d4e3e01071c97c2bac51cdd6fe97
- https://huntr.dev/bounties/351f9055-2008-4af0-b820-01ff66678bf3
Get alerted when CVE-2023-2227 or the next vulnerability affects your stack