What’s Vulnerable › Vulnerabilities

CVE-2023-22323: BIG-IP SSL OCSP Authentication profile vulnerability

Description

In BIP-IP versions 17.0.x before 17.0.0.2, 16.1.x before 16.1.3.3, 15.1.x before 15.1.8.1, 14.1.x before 14.1.5.3, and all versions of 13.1.x, when OCSP authentication profile is configured on a virtual server, undisclosed requests can cause an increase in CPU resource utilization. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Affected products

How to fix

Upgrade to a fixed version: F5 BIG-IP APM 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; BIG-IP 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 Big-Ip Analytics 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 Networks, Inc. BIG-IP (AAM) 15.1.8.1, 16.1.3.3, 17.0.0.2; BIG-IP ASM 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 Big-Ip Ddos Hybrid Defender 14.1.5.3, 15.1.8.1, 16.1.3.3; F5 BIG-IP DNS 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 Big-Ip Fraud Protection Service 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 Big-Ip Link Controller 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 BIG-IP (LTM) 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 Networks, Inc. BIG-IP (PEM) 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2; F5 Big-Ip Ssl Orchestrator 14.1.5.3, 15.1.8.1, 16.1.3.3, 17.0.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-22323 or the next vulnerability affects your stack