What’s Vulnerable › Vulnerabilities
CVE-2023-22332
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-312
Description
Information disclosure vulnerability exists in Pgpool-II 4.4.0 to 4.4.1 (4.4 series), 4.3.0 to 4.3.4 (4.3 series), 4.2.0 to 4.2.11 (4.2 series), 4.1.0 to 4.1.14 (4.1 series), 4.0.0 to 4.0.21 (4.0 series), All versions of 3.7 series, All versions of 3.6 series, All versions of 3.5 series, All versions of 3.4 series, and All versions of 3.3 series. A specific database user's authentication information may be obtained by another database user. As a result, the information stored in the database may be altered and/or database may be suspended by a remote attacker who successfully logged in the product with the obtained credentials.
Affected products
- PgPool Global Development Group Pgpool-II: from 3.3.0 through 3.7.12; from 4.0.0 before 4.0.22; from 4.1.0 before 4.1.15; from 4.2.0 before 4.2.12; from 4.3.0 before 4.3.5; from 4.4.0 before 4.4.2 — fixed in 4.0.22, 4.1.15, 4.2.12, 4.3.5, 4.4.2
How to fix
Upgrade to a fixed version: PgPool Global Development Group Pgpool-II 4.0.22, 4.1.15, 4.2.12, 4.3.5. Check the vendor advisory for mitigations.
References
- https://jvn.jp/en/jp/JVN72418815/
- https://www.pgpool.net/mediawiki/index.php/Main_Page#News
- https://jvn.jp/en/jp/JVN72418815/
- https://lists.debian.org/debian-lts-announce/2024/12/msg00015.html
- https://www.pgpool.net/mediawiki/index.php/Main_Page#News
Get alerted when CVE-2023-22332 or the next vulnerability affects your stack