What’s Vulnerable › Vulnerabilities
CVE-2023-22451: Weak password requirements in Kiwi TCMS
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-02 · updated 2026-06-17
- Weakness: CWE-521
Description
Kiwi TCMS is an open source test management system. In version 11.6 and prior, when users register new accounts and/or change passwords, there is no validation in place which would prevent them from picking an easy to guess password. This issue is resolved by providing defaults for the `AUTH_PASSWORD_VALIDATORS` configuration setting. As of version 11.7, the password can’t be too similar to other personal information, must contain at least 10 characters, can’t be a commonly used password, and can’t be entirely numeric. As a workaround, an administrator may reset all passwords in Kiwi TCMS if they think a weak password may have been chosen.
Affected products
- kiwitcms Kiwi: before 11.7 — fixed in 11.7
How to fix
Upgrade to a fixed version: kiwitcms Kiwi 11.7. Check the vendor advisory for mitigations.
References
- https://github.com/kiwitcms/Kiwi/commit/3759fb68aed36315cdde9fc573b2fe7c11544985
- https://github.com/kiwitcms/Kiwi/security/advisories/GHSA-496x-2jqf-hp7g
- https://huntr.dev/bounties/32a873c8-f605-4aae-9272-d80985ef2b73
- https://github.com/kiwitcms/Kiwi/commit/3759fb68aed36315cdde9fc573b2fe7c11544985
- https://github.com/kiwitcms/Kiwi/security/advisories/GHSA-496x-2jqf-hp7g
- https://huntr.dev/bounties/32a873c8-f605-4aae-9272-d80985ef2b73
Get alerted when CVE-2023-22451 or the next vulnerability affects your stack