What’s Vulnerable › Vulnerabilities
CVE-2023-22453: Discourse vulnerable to exposure of user post counts per topic to unauthorized users
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-05 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 3.0.0.beta16 on the `beta` and `tests-passed` branches, the number of times a user posted in an arbitrary topic is exposed to unauthorized users through the `/u/username.json` endpoint. The issue is patched in version 2.8.14 and 3.0.0.beta16. There is no known workaround.
Affected products
- discourse: before 2.8.14; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+199) — fixed in 2.8.14
How to fix
Upgrade to a fixed version: discourse 2.8.14. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/cbcf8a064b4889a19c991641e09c399bfa1ef2ad
- https://github.com/discourse/discourse/security/advisories/GHSA-xx97-6494-p2rv
- https://github.com/discourse/discourse/commit/cbcf8a064b4889a19c991641e09c399bfa1ef2ad
- https://github.com/discourse/discourse/security/advisories/GHSA-xx97-6494-p2rv
Get alerted when CVE-2023-22453 or the next vulnerability affects your stack