What’s Vulnerable › Vulnerabilities
CVE-2023-22454: Discourse vulnerable to Cross-site Scripting through pending post titles descriptions
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 3.0.0.beta16 on the `beta` and `tests-passed` branches, pending post titles can be used for cross-site scripting attacks. Pending posts can be created by unprivileged users when a category has the "require moderator approval of all new topics" setting set. This vulnerability can lead to a full XSS on sites which have modified or disabled Discourse’s default Content Security Policy. A patch is available in versions 2.8.14 and 3.0.0.beta16.
Affected products
- discourse: before 2.8.14; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+199) — fixed in 2.8.14
How to fix
Upgrade to a fixed version: discourse 2.8.14. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/c0e2d7badac276d82a4056a994b48d68a8993a12
- https://github.com/discourse/discourse/security/advisories/GHSA-ggq4-4qxc-c462
- https://github.com/discourse/discourse/commit/c0e2d7badac276d82a4056a994b48d68a8993a12
- https://github.com/discourse/discourse/security/advisories/GHSA-ggq4-4qxc-c462
Get alerted when CVE-2023-22454 or the next vulnerability affects your stack