What’s Vulnerable › Vulnerabilities
CVE-2023-22455: Discourse vulnerable to Cross-site Scripting through tag descriptions
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 3.0.0.beta16 on the `beta` and `tests-passed` branches, tag descriptions, which can be updated by moderators, can be used for cross-site scripting attacks. This vulnerability can lead to a full XSS on sites which have modified or disabled Discourse’s default Content Security Policy. Versions 2.8.14 and 3.0.0.beta16 contain a patch.
Affected products
- discourse: before 2.8.14; 1.1.0-beta1, 1.1.0-beta2, 1.1.0-beta3, 1.1.0-beta4, 1.1.0-beta5, 1.1.0-beta6 (+199) — fixed in 2.8.14
How to fix
Upgrade to a fixed version: discourse 2.8.14. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/692329896ac64d8581947e977202c243eef3b5a2
- https://github.com/discourse/discourse/security/advisories/GHSA-5rq6-466r-6mr9
- https://github.com/discourse/discourse/commit/692329896ac64d8581947e977202c243eef3b5a2
- https://github.com/discourse/discourse/security/advisories/GHSA-5rq6-466r-6mr9
Get alerted when CVE-2023-22455 or the next vulnerability affects your stack