What’s Vulnerable › Vulnerabilities
CVE-2023-22458: Integer overflow in multiple Redis commands can lead to denial-of-service
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 72.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-190
Description
Redis is an in-memory database that persists on disk. Authenticated users can issue a `HRANDFIELD` or `ZRANDMEMBER` command with specially crafted arguments to trigger a denial-of-service by crashing Redis with an assertion failure. This problem affects Redis versions 6.2 or newer up to but not including 6.2.9 as well as versions 7.0 up to but not including 7.0.8. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Redis: from 6.2.0 before 6.2.9; from 7.0.0 before 7.0.8 — fixed in 6.2.9, 7.0.8
How to fix
Upgrade to a fixed version: Redis 6.2.9, 7.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/16f408b1a0121cacd44cbf8aee275d69dc627f02
- https://github.com/redis/redis/releases/tag/6.2.9
- https://github.com/redis/redis/releases/tag/7.0.8
- https://github.com/redis/redis/security/advisories/GHSA-r8w2-2m53-gprj
- https://github.com/redis/redis/commit/16f408b1a0121cacd44cbf8aee275d69dc627f02
- https://github.com/redis/redis/releases/tag/6.2.9
- https://github.com/redis/redis/releases/tag/7.0.8
- https://github.com/redis/redis/security/advisories/GHSA-r8w2-2m53-gprj
Get alerted when CVE-2023-22458 or the next vulnerability affects your stack