What’s Vulnerable › Vulnerabilities
CVE-2023-22463: KubePi's Hardcoded Jwtsigkeys allows malicious actor to login with a forged JWT token
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 69.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-04 · updated 2026-06-17
- Weakness: CWE-798
Description
KubePi is a k8s panel. The jwt authentication function of KubePi through version 1.6.2 uses hard-coded Jwtsigkeys, resulting in the same Jwtsigkeys for all online projects. This means that an attacker can forge any jwt token to take over the administrator account of any online project. Furthermore, they may use the administrator to take over the k8s cluster of the target enterprise. `session.go`, the use of hard-coded JwtSigKey, allows an attacker to use this value to forge jwt tokens arbitrarily. The JwtSigKey is confidential and should not be hard-coded in the code. The vulnerability has been fixed in 1.6.3. In the patch, JWT key is specified in app.yml. If the user leaves it blank, a random key will be used. There are no workarounds aside from upgrading.
Affected products
- 1Panel-dev KubePi: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: 1Panel-dev KubePi 1.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/KubeOperator/KubePi/blob/da784f5532ea2495b92708cacb32703bff3a45a3/internal/api/v1/session/session.go#L35
- https://github.com/KubeOperator/KubePi/commit/3be58b8df5bc05d2343c30371dd5fcf6a9fbbf8b
- https://github.com/KubeOperator/KubePi/releases/tag/v1.6.3
- https://github.com/KubeOperator/KubePi/security/advisories/GHSA-vjhf-8vqx-vqpq
- https://github.com/KubeOperator/KubePi/blob/da784f5532ea2495b92708cacb32703bff3a45a3/internal/api/v1/session/session.go#L35
- https://github.com/KubeOperator/KubePi/commit/3be58b8df5bc05d2343c30371dd5fcf6a9fbbf8b
- https://github.com/KubeOperator/KubePi/releases/tag/v1.6.3
- https://github.com/KubeOperator/KubePi/security/advisories/GHSA-vjhf-8vqx-vqpq
Get alerted when CVE-2023-22463 or the next vulnerability affects your stack