What’s Vulnerable › Vulnerabilities
CVE-2023-22468: Discourse vulnerable to Cross-site Scripting in local oneboxes
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open source platform for community discussion. Versions prior to 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed), are vulnerable to cross-site Scripting. A maliciously crafted URL can be included in a post to carry out cross-site scripting attacks on sites with disabled or overly permissive CSP (Content Security Policy). Discourse's default CSP prevents this vulnerability. This vulnerability is patched in versions 2.8.13 (stable), 3.0.0.beta16 (beta) and 3.0.0beta16 (tests-passed). As a workaround, enable and/or restore your site's CSP to the default one provided with Discourse.
Affected products
- discourse: before 2.8.13; 2.9.0-beta1, 2.9.0-beta10, 2.9.0-beta11, 2.9.0-beta12, 2.9.0-beta13, 2.9.0-beta14 (+9) — fixed in 2.8.13
How to fix
Upgrade to a fixed version: discourse 2.8.13. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/security/advisories/GHSA-8mr2-xf8r-wr8m
- https://github.com/discourse/discourse/security/advisories/GHSA-8mr2-xf8r-wr8m
Get alerted when CVE-2023-22468 or the next vulnerability affects your stack