What’s Vulnerable › Vulnerabilities
CVE-2023-22470: Nextcloud Deck vulnerable to uncontrolled resource consumption
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-14 · updated 2026-06-17
- Weakness: CWE-400
Description
Nextcloud Deck is a kanban style organization tool aimed at personal planning and project organization for teams integrated with Nextcloud. A database error can be generated potentially causing a DoS when performed multiple times. There are currently no known workarounds. It is recommended that the Nextcloud Server is upgraded to 1.6.5 or 1.7.3 or 1.8.2.
Affected products
- Nextcloud Deck: before 1.6.5; from 1.7.0 before 1.7.3; from 1.8.0 before 1.8.2 — fixed in 1.6.5, 1.7.3, 1.8.2
How to fix
Upgrade to a fixed version: Nextcloud Deck 1.6.5, 1.7.3, 1.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/deck/pull/4059
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-93j5-wx4c-6g88
- https://github.com/nextcloud/deck/pull/4059
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-93j5-wx4c-6g88
Get alerted when CVE-2023-22470 or the next vulnerability affects your stack