What’s Vulnerable › Vulnerabilities
CVE-2023-22477: Mercurius is vulnerable to denial of service (DoS) when using subscriptions
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-09 · updated 2026-06-17
- Weakness: CWE-248
Description
Mercurius is a GraphQL adapter for Fastify. Any users of Mercurius until version 10.5.0 are subjected to a denial of service attack by sending a malformed packet over WebSocket to `/graphql`. This issue was patched in #940. As a workaround, users can disable subscriptions.
Affected products
- mercurius-js mercurius: before 8.13.2; from 9.0.0 before 11.5.0 — fixed in 11.5.0, 8.13.2
How to fix
Upgrade to a fixed version: mercurius-js mercurius 11.5.0, 8.13.2. Check the vendor advisory for mitigations.
References
- https://github.com/mercurius-js/mercurius/issues/939
- https://github.com/mercurius-js/mercurius/pull/940
- https://github.com/mercurius-js/mercurius/security/advisories/GHSA-cm8h-q92v-xcfc
- https://github.com/mercurius-js/mercurius/issues/939
- https://github.com/mercurius-js/mercurius/pull/940
- https://github.com/mercurius-js/mercurius/security/advisories/GHSA-cm8h-q92v-xcfc
Get alerted when CVE-2023-22477 or the next vulnerability affects your stack