What’s Vulnerable › Vulnerabilities
CVE-2023-22478: KubePi is vulnerable to missing authorization
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-14 · updated 2026-06-17
- Weakness: CWE-862
Description
KubePi is a modern Kubernetes panel. The API interfaces with unauthorized entities and may leak sensitive information. This issue has been patched in version 1.6.4. There are currently no known workarounds.
Affected products
- 1Panel-dev KubePi: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: 1Panel-dev KubePi 1.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/KubeOperator/KubePi/commit/0c6774bf5d9003ae4d60257a3f207c131ff4a6d6
- https://github.com/KubeOperator/KubePi/releases/tag/v1.6.4
- https://github.com/KubeOperator/KubePi/security/advisories/GHSA-gqx8-hxmv-c4v4
- https://github.com/KubeOperator/KubePi/commit/0c6774bf5d9003ae4d60257a3f207c131ff4a6d6
- https://github.com/KubeOperator/KubePi/releases/tag/v1.6.4
- https://github.com/KubeOperator/KubePi/security/advisories/GHSA-gqx8-hxmv-c4v4
Get alerted when CVE-2023-22478 or the next vulnerability affects your stack