What’s Vulnerable › Vulnerabilities
CVE-2023-22479: KubePi vulnerable to session fixation attack
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-384
Description
KubePi is a modern Kubernetes panel. A session fixation attack allows an attacker to hijack a legitimate user session, versions 1.6.3 and below are susceptible. A patch will be released in version 1.6.4.
Affected products
- 1Panel-dev KubePi: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: 1Panel-dev KubePi 1.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/KubeOperator/KubePi/security/advisories/GHSA-v4w5-r2xc-7f8h
- https://github.com/KubeOperator/KubePi/security/advisories/GHSA-v4w5-r2xc-7f8h
Get alerted when CVE-2023-22479 or the next vulnerability affects your stack