What’s Vulnerable › Vulnerabilities
CVE-2023-22480: KubeOperator is vulnerable to unauthorized access to system API
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 66.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-14 · updated 2026-06-17
- Weakness: CWE-285
Description
KubeOperator is an open source Kubernetes distribution focused on helping enterprises plan, deploy and operate production-level K8s clusters. In KubeOperator versions 3.16.3 and below, API interfaces with unauthorized entities and can leak sensitive information. This vulnerability could be used to take over the cluster under certain conditions. This issue has been patched in version 3.16.4.
Affected products
- KubeOperator: before 3.16.4 — fixed in 3.16.4
How to fix
Upgrade to a fixed version: KubeOperator 3.16.4. Check the vendor advisory for mitigations.
References
- https://github.com/KubeOperator/KubeOperator/commit/7ef42bf1c16900d13e6376f8be5ecdbfdfb44aaf
- https://github.com/KubeOperator/KubeOperator/releases/tag/v3.16.4
- https://github.com/KubeOperator/KubeOperator/security/advisories/GHSA-jxgp-jgh3-8jc8
- https://github.com/KubeOperator/KubeOperator/commit/7ef42bf1c16900d13e6376f8be5ecdbfdfb44aaf
- https://github.com/KubeOperator/KubeOperator/releases/tag/v3.16.4
- https://github.com/KubeOperator/KubeOperator/security/advisories/GHSA-jxgp-jgh3-8jc8
Get alerted when CVE-2023-22480 or the next vulnerability affects your stack