What’s Vulnerable › Vulnerabilities
CVE-2023-22491: gatsby-transformer-remark vulnerable to unsanitized JavaScript code injection
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-13 · updated 2026-09-29
- Weakness: CWE-20
Description
Gatsby is a free and open source framework based on React that helps developers build websites and apps. The gatsby-transformer-remark plugin prior to versions 5.25.1 and 6.3.2 passes input through to the `gray-matter` npm package, which is vulnerable to JavaScript injection in its default configuration, unless input is sanitized. The vulnerability is present in gatsby-transformer-remark when passing input in data mode (querying MarkdownRemark nodes via GraphQL). Injected JavaScript executes in the context of the build server. To exploit this vulnerability untrusted/unsanitized input would need to be sourced by or added into a file processed by gatsby-transformer-remark. A patch has been introduced in `gatsby-transformer-remark@5.25.1` and `gatsby-transformer-remark@6.3.2` which mitigates the issue by disabling the `gray-matter` JavaScript Frontmatter engine. As a workaround, if an older version of `gatsby-transformer-remark` must be used, input passed into the plugin should be sanitized ahead of processing. It is encouraged for projects to upgrade to the latest major release branch for all Gatsby plugins to ensure the latest security updates and bug fixes are received in a timely manner.
Affected products
- gatsbyjs Gatsby-Transformer-Remark: before 5.25.1; from 6.0.0 before 6.3.2 — fixed in 5.25.1, 6.3.2
How to fix
Upgrade to a fixed version: gatsbyjs Gatsby-Transformer-Remark 5.25.1, 6.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-7ch4-rr99-cqcw
- https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-7ch4-rr99-cqcw
- https://github.com/gatsbyjs/gatsby/security/advisories/GHSA-7ch4-rr99-cqcw
Get alerted when CVE-2023-22491 or the next vulnerability affects your stack