What’s Vulnerable › Vulnerabilities
CVE-2023-22499: Interactive permission prompt spoofing in Deno
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-362
Description
Deno is a runtime for JavaScript and TypeScript that uses V8 and is built in Rust. Multi-threaded programs were able to spoof interactive permission prompt by rewriting the prompt to suggest that program is waiting on user confirmation to unrelated action. A malicious program could clear the terminal screen after permission prompt was shown and write a generic message. This situation impacts users who use Web Worker API and relied on interactive permission prompt. The reproduction is very timing sensitive and can’t be reliably reproduced on every try. This problem can not be exploited on systems that do not attach an interactive prompt (for example headless servers). The problem has been fixed in Deno v1.29.3; it is recommended all users update to this version. Users are advised to upgrade. Users unable to upgrade may run with --no-prompt flag to disable interactive permission prompts.
Affected products
- denoland deno: from 1.9.0 before 1.29.3 — fixed in 1.29.3
How to fix
Upgrade to a fixed version: denoland deno 1.29.3. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/pull/17392
- https://github.com/denoland/deno/security/advisories/GHSA-mc52-jpm2-cqh6
- https://github.com/denoland/deno/pull/17392
- https://github.com/denoland/deno/security/advisories/GHSA-mc52-jpm2-cqh6
Get alerted when CVE-2023-22499 or the next vulnerability affects your stack