What’s Vulnerable › Vulnerabilities
CVE-2023-22504
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-25 · updated 2026-06-17
- Weakness: CWE-434
Description
Affected versions of Atlassian Confluence Server allow remote attackers who have read permissions to a page, but not write permissions, to upload attachments via a Broken Access Control vulnerability in the attachments feature.
Affected products
- Atlassian Confluence Data Center: before 7.13.17; from 7.14.0 before 7.19.9; from 7.20.0 before 8.2.2 — fixed in 7.13.17, 7.19.9, 8.2.2
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.13.17, 7.19.9, 8.2.2. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-83218
- https://jira.atlassian.com/browse/CONFSERVER-83218
Get alerted when CVE-2023-22504 or the next vulnerability affects your stack