What’s Vulnerable › Vulnerabilities
CVE-2023-22505
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-18 · updated 2026-06-17
Description
This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22505 was introduced in version 8.0.0 of Confluence Data Center & Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to latest version. If you're unable to upgrade to latest, upgrade to one of these fixed versions: 8.3.2, 8.4.0. See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html).|https://confluence.atlassian.com/doc/confluence-release-notes-327.html).] You can download the latest version of Confluence Data Center & Server from the download center ([https://www.atlassian.com/software/confluence/download-archives).|https://www.atlassian.com/software/confluence/download-archives).] This vulnerability was discovered by a private user and reported via our Bug Bounty program.
Affected products
- Atlassian Confluence Data Center: from 8.0.0 before 8.3.2 — fixed in 8.3.2
- Atlassian Confluence Data Center: from 8.0.0 before 8.3.2 — fixed in 8.3.2
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 8.3.2; Atlassian Confluence Data Center 8.3.2. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-88265
- https://jira.atlassian.com/browse/CONFSERVER-88265
Get alerted when CVE-2023-22505 or the next vulnerability affects your stack