What’s Vulnerable › Vulnerabilities
CVE-2023-22506
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-19 · updated 2026-06-17
- Weakness: CWE-94
Description
This High severity Injection and RCE (Remote Code Execution) vulnerability known as CVE-2023-22506 was introduced in version 8.0.0 of Bamboo Data Center. This Injection and RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.5, allows an authenticated attacker to modify the actions taken by a system call and execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to latest version. If you're unable to upgrade to latest, upgrade to one of these fixed versions: 9.2.3 and 9.3.1. See the release notes ([https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html|https://confluence.atlassian.com/bambooreleases/bamboo-release-notes-1189793869.html]). You can download the latest version of Bamboo Data Center and Bamboo Server from the download center ([https://www.atlassian.com/software/bamboo/download-archives|https://www.atlassian.com/software/bamboo/download-archives]). This vulnerability was reported via our Penetration Testing program.
Affected products
- Atlassian Bamboo Data Center: from 8.0.0 before 9.2.3 — fixed in 9.2.3
- Atlassian Bamboo Server: from 8.0.0 before 9.2.3 — fixed in 9.2.3
How to fix
Upgrade to a fixed version: Atlassian Bamboo Data Center 9.2.3; Atlassian Bamboo Server 9.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-22506 or the next vulnerability affects your stack