What’s Vulnerable › Vulnerabilities
CVE-2023-22508
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-18 · updated 2026-06-17
Description
This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22508 was introduced in version 6.1.0 of Confluence Data Center & Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to avoid this bug using the following options: * Upgrade to a Confluence feature release greater than or equal to 8.2.0 (ie: 8.2, 8.2, 8.4, etc...) * Upgrade to a Confluence 7.19 LTS bugfix release greater than or equal to 7.19.8 (ie: 7.19.8, 7.19.9, 7.19.10, 7.19.11, etc...) * Upgrade to a Confluence 7.13 LTS bugfix release greater than or equal to 7.13.20 (Release available early August) See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Data Center & Server from the download center (https://www.atlassian.com/software/confluence/download-archives ). If you are unable to upgrade your instance please use the following guide to workaround the issue https://confluence.atlassian.com/confkb/how-to-disable-the-jmx-network-port-for-cve-2023-22508-1267761550.html This vulnerability was discovered by a private user and reported via our Bug Bounty program.
Affected products
- Atlassian Confluence Data Center: from 6.1.0 before 7.13.20; from 7.14.0 before 7.19.8; from 7.20.0 before 8.2.0 — fixed in 7.13.20, 7.19.8, 8.2.0
- Atlassian Confluence Data Center: from 6.1.0 before 7.13.20; from 7.14.0 before 7.19.8; from 7.20.0 before 8.2.0 — fixed in 7.13.20, 7.19.8, 8.2.0
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 7.13.20, 7.19.8, 8.2.0; Atlassian Confluence Data Center 7.13.20, 7.19.8, 8.2.0. Check the vendor advisory for mitigations.
References
- https://jira.atlassian.com/browse/CONFSERVER-88221
- https://jira.atlassian.com/browse/CONFSERVER-88221
Get alerted when CVE-2023-22508 or the next vulnerability affects your stack