What’s Vulnerable › Vulnerabilities
CVE-2023-22515: Atlassian Confluence Data Center and Server Broken Access Control Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-10-05
- EPSS: 99.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-04 · updated 2026-06-17
- Weakness: CWE-20
Description
Atlassian has been made aware of an issue reported by a handful of customers where external attackers may have exploited a previously unknown vulnerability in publicly accessible Confluence Data Center and Server instances to create unauthorized Confluence administrator accounts and access Confluence instances. Atlassian Cloud sites are not affected by this vulnerability. If your Confluence site is accessed via an atlassian.net domain, it is hosted by Atlassian and is not vulnerable to this issue.
Affected products
- Atlassian Confluence Data Center: from 8.0.0 before 8.3.3; from 8.4.0 before 8.4.3; from 8.5.0 before 8.5.2 — fixed in 8.3.3, 8.4.3, 8.5.2
- Atlassian Confluence Data Center: from 8.0.0 before 8.3.3; from 8.4.0 before 8.4.3; from 8.5.0 before 8.5.2 — fixed in 8.3.3, 8.4.3, 8.5.2
How to fix
Upgrade to a fixed version: Atlassian Confluence Data Center 8.3.3, 8.4.3, 8.5.2; Atlassian Confluence Data Center 8.3.3, 8.4.3, 8.5.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/175225/Atlassian-Confluence-Unauthenticated-Remote-Code-Execution.html
- https://confluence.atlassian.com/display/KB/FAQ+for+CVE-2023-22515
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1295682276
- https://jira.atlassian.com/browse/CONFSERVER-92475
- http://packetstormsecurity.com/files/175225/Atlassian-Confluence-Unauthenticated-Remote-Code-Execution.html
- https://confluence.atlassian.com/display/KB/FAQ+for+CVE-2023-22515
- https://confluence.atlassian.com/pages/viewpage.action?pageId=1295682276
- https://jira.atlassian.com/browse/CONFSERVER-92475
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-22515
Get alerted when CVE-2023-22515 or the next vulnerability affects your stack